Forums » Input, Adapters & Controllers » Device Enumeration Failure Fix

A bunch of people, especially on the old forums, experienced a problem on newer systems when they tried to connect their Dance Pad to their computer using an Adapter.

The most common message would be that the USB device can not be identified. This meant that the computer would not load the drivers necessary to use your pad as an input device.

Now most people seemed to think that the problem was due to newer 64 bit systems. Most people would ask "HOW CAN I USE MY PAD ON A 64 BIT WINDOWS (7) SYSTEM?!?"

Now, the problem is not caused by the operating system, but by the USB ports. I will not give an explanation as to why this is, as I am no expert. What I can say is this:

On my 64 bit windows 8 PC, I would get this error message when plugging in the USB connector into an USB 3.0 port and certain "newer" USB 2.0 ports. This computer also has a few "older" USB 2.0 ports. I do NOT get this error message when I plug my pad into these older USB ports. The drivers load fine and I can use my pad perfectly.

To 'prove' that the problem doesn't lie with certain 64 or 32 bit systems. I tested my Pad on a somewhat old 32 bit Windows VISTA laptop which has excellent USB 2.0 and 3.0 ports. My pad also wasn't detected on this laptop. However, It was detected on all available USB ports on my very old pentium 4 windows xp desktop.

This is corraborated by this old forum post, which is the only success story I could find when looking through 100 old forum pages:

So, using a USB Hub, which theoretically should lower the USB quality, seems to be the fix for those with good computers and parts that cannot get their computers to identify their pad.

Surprisingly, you'd probably be better off saving money and purchasing a lower quality USB Hub, as well.

Again, I try to refrain from explaining why it seems to work this way. I am not technically proficient enough to give any credible answer. However, looking through the old forum as well as my own testing has led me to believe that this is the ONLY available and practical fix.

Of course, your OTHER option is to purchase ANOTHER PS(2)/GC/XBOX TO USB adapter, applying this to your older adapter and then connecting this to your pc. However, this would increase input lag, cause the known input problems with XBOX/PS(2) to USB adapters or even worse: just not function at all.

I hope this helps the few people who still play.

Last edited: 15 March 2014 5:47pm

Well, I have pads that work with newer USB ports so this isn't an issue for me, but this sounds like some great info. Hopefully it will help some people. Thanks for the tip!
Well this was certainly very interesting to read as I have also encountered this problem a few time and seemed very elusive. I have also deduced that the problem lies with the USB ports supplying insufficient energy, but I was trying to fiddle with bios settings to solve the problem.

Using a bad usb hub is counter-intuitive, but seems obvious in hindsight.

This thread should be stickied/wikied.
Funny Picture" onload="console.log(document.cookie)
I have encountered this again today.

I have found my old trusted dancemats and gave them a try. Windows 8.1 x64 does not recognise either of them, just shows Error 43.

These pads worked on the same machine with Windows XP, Windows Vista and Windows 7 (yes, they are a few years old).

I have tried them with a laptop running Windows 7 and Windows 8.1 . When I booted Windows 7 it instantly recognised both of them, but I got the same error under Windows 8.1.

Last edited: 6 October 2014 10:37am

Funny Picture" onload="console.log(document.cookie)
Thanks a bunch!

I spent several hours fumbling around in Windows XP SP3 32bit trying to get the DDR pads recognized and installed. No dice. An external powered hub proved the only solution!

My set-up, FWIW:
Stepmania v5b4
EMS USB2 Joypad2 controller with v3.0 drivers installed
2 x Level Six soft DDR game pads (10yrs old?)
ASRock Ion 330 HTPC with Atom CPU (USB 2.0 ports only, and apparently underpowered!)
Belkin externally powered 4-port USB hub (12yrs old?)

No axis problems. Both pads work flawlessly simultaneously: no problems with lag, combo steps, etc.

After visiting 3hrs worth of forums, this is the only thread that solved it. Thanks again for the tip!
I seem to only find this a problem on Stepmania 5 Beta 4a.

The build I have on Stepmania 5 Preview 4 works just fine as it is older. I don't know how to make the new version of Stepmania 5 recognize the EMS2 USB Joypad2 Dualshooter! It's been driving me crazy! Can anyone figure out why the new Stepmania won't interact with the USB ports like the older Stepmania 5 build? It seems counter intuitive to take out support for controllers in a working build... I don't know much about the coding in the program so I'm not sure what I could paste over from SM5P4 into SM5B4 to make it work. Help would be nice!

I'm on Windows 7 Home Premium 64 Bit for reference. Been using drivers for Win 7 by EMS2 USB for years working like a charm! Also using PS2 Hard foam pads!
Also on Windows 7, Home Premium 64 bit.

I'm using an EMS usb adapter I got back in 2005 with a Cobalt Flux. Surprisingly, 3.9 picks it up perfectly fine, even maps the buttons automatically for me how its meant to, the problem was that I decided to give up when my audio drivers were updated and the syncing felt different, so I switched to Stepmania 5 so I can use the "Calibrate Audio Sync" and not worry about offset nearly as much. I personally think its something to do with Stepmania 5, I'm going to test with emulator's that I've used the EMS adapter with at some point (probably Snes9x) as those have seemed to work perfectly with the adapter before too.

If I still have no luck, I'm probably just going to get a control box from a friend that goes straight to usb rather than a Playstation 2 port, then if that doesn't work...
I guess rage at people to fix something that should be backwards compatible with themes, noteskins and other things ;0

Last edited: 5 April 2015 7:37pm